RLC自动化

RLC自动化

Notes
客户需求及问题:

      一线工程师之前是“请求已提交”状态。那个状态客户需要跳过,希望RLC过程通过配置了一定的规则,用户提交之后根据特定字段的值来自动到达“一线工程师”或“事件经理”
以下是RLC配置,客户设置了业务规则,但实际测试时发现会有第一张图的报错,如果没有配置该规则,则工单将流转至“请求已提交”状态。

Idea
问题原因:
      由于业务规则的触发时机刚好在RLC之前,因此业务规则执行完后再去继续执行一遍RLC流程,这时RLC流程中没有直接跳转某个过程,因此,前端会有没有找到转换过程的报错。

Idea
解决方案:
      思路:因为自定义触发器的执行过程刚好在RLC之后,因此可以改为用自定义触发器来实现类似需求。
这里抛砖迎玉,用一个测试环境的demo来说明。
      1 如下图为一个最简单的RLC,这里的Hold和Assign过程是类比上述的不同条件判断。RLC完成流程图之后,自动化调整逻辑来到自定义触发器中来写。
      2 比如说,某一条链路的值满足XX条件,如分类满足条件,然后执行自定义函数。
        3 自定义函数的内容为,更新状态值为需要的状态,然后其会自动基于RLC往下走。      
完整代码:(其中name值为实际RLC状态值部分,做直接替换)。
returnobj = {
    "message": "Request Updated Successfully",
    "result": "success",
    "operation": [
        {
            "OPERATIONNAME": "UPDATE",
            "FORMAT": "V3",
            "INPUT_DATA": [
                {
                    "request": {
                        "status": {
                            "name": "Assigned"
                        }
                    }
                }
            ]
        }
    ]
};

return returnobj;
      4 效果。当创建时直接满足了条件,则会自动化的进行业务流转。不需再人工点击Assign。


    • Related Articles

    • 已知问题|业务规则不生效/服务业务规则无法打开/生命周期点开报错/无法编辑RLC规则/自定义触发器无法打开

      问题现象 业务规则不生效/服务业务规则无法打开/生命周期点开报错/无法编辑RLC规则/自定义触发器无法打开 问题排查 打开网页抓包,如果发现调用了此api/v3/requests/_metainfo并报错"Internal error"。则可以确认是已知问题。 临时解决方法 1、复现问题,查看/logs/serverout0.txt日志。 2、可以找到如下报错,Service ID可能不同。 ...
    • PMP & PAM360 视频会话转化为MP4格式

      由于视频经过了压缩和特殊处理,在PAM360上进行快进和退出功能是不好用的,对于一些特定文件需要审计有快进快退需求时建议您先转为mp4类型的文件然后再在您的播放器上进行快进播放。转化工具下载。 附件下载 converter.txt 文件 下载完毕后修改后缀名为converter.jar 安装到: <pam_home & pmp>/jre/bin. 并在当前bin目录下执行java -jar converter.jar -s ...