在尝试监控JBoss时,我没有获得JVM和EJB详细信息,同时在顶部出现一条消息“选择JBoss版本。编辑监视器从而更改版本。”

在尝试监控JBoss时,我没有获得JVM和EJB详细信息,同时在顶部出现一条消息“选择JBoss版本。编辑监视器从而更改版本。”

原因:

JBoss在Applications Manager中自动被发现。但是JBoss实例的版本没有更新。

解决方案:

要获取JVM、JDBC和EJB详细信息,请点击“配置”选项并输入JBoss服务器的版本(3.2.x、4.x)。


    • Related Articles

    • 在尝试监控JBoss 时,我收到一个错误消息“无法收集<主机名>的数据”,并且JVM和EJB详细信息缺失。

      原因一:jbossagent.sar没有部署到JBoss服务器中 Applications Manager通过直接连接到JBoss JNDI命名服务来收集JBoss MBean的详细信息。默认使用JBoss安装的应用程序http-invoker.sar用于访问JBoss JNDI服务。 理想情况下,一旦发现jbossagent.sar,就应该由Applications Manager自动部署到JBoss服务器中。如果没有即时部署,您将收到“无法收集数据”消息。 Applications ...
    • 在尝试监控JBoss时,我收到消息“没有为此服务器配置JDBC连接池”。

      原因:  在JBoss服务器中尚未配置数据库连接池。 解决方案: 检查JBoss部署目录中是否有格式为 “*-ds.xml” 的文件。如果不存在,则表示尚未配置数据库连接池,这就是显示此类错误的原因。 
    • OPM下如何查看tomcat版本?

      解压OpManager\lib\tomcat目录下的catalina.jar    打开META-INF文件夹下的 MANIFEST.MF文件,找到'Implementation-Version' 显示 tomcat 版本。
    • 13 XXX 版本升级到14205版本升级问题。

      目前有在客户环境中遇到13XXX版本升级14205版本两个报错,可以在相同升级前额外注意提前检查是否存在相同问题,或者在发现相同报错时采取下列解决方案。 升级包 https://download.manageengine.com/products/service-desk/91677414/ManageEngine_ServiceDesk_Plus_14_2_0_SP-0_5_0.ppm ...
    • 将OpManager升级到最新版本

      问题:如何将OpManager升级到最新版本。 解决方案: 根据当前版本,选择以下升级路径。 8000/8721/8723/8800                                            ->> 8810                              8810/8811/8812/9000                                            ->> 9010                                ...